Overview
eFORMz logs might contain one or more of different types of memory errors. This article provides guides to help you address them:
- Out of Memory exception.
- GC (garbage collection) exception.
- Other memory exceptions.
Symptoms
You notice printing becoming very slow, or the entire server almost unresponsive as eFORMz struggles with a Java memory problem.
Possible Causes
An Out of Memory error is sometimes the result of a problem that Java cannot resolve. For example, invalid XML files that eFORMz cannot process have been known to result in memory problems as Java attempts to process invalid XML. Setting up Director Alerts can help avoid this problem by placing the invalid file in quarantine. However, the best approach is to create only valid XML files.
If the eFORMz logs include garbage collection (GC) errors, the operating system is in a confused state and should be restarted. Please also check the following conditions:
- Available disk space where eFORMz is installed and any volumes to which eFORMz writes files. The solution for this condition, of course, is more disk space.
- One or more data files that are unusually large. We've seen eFORMz processing files that were typically under 10 KB. One file was 144 MB and it caused numerous issues. One way to fix this issue is to add a file size selector in the configuration file’s file selector. For example, set it to select files that are less than 1 MB.
- One or more data files that is caught in a loop. The solution for this is a Director Alert, as described above.
Troubleshooting Steps
First, check how much memory is allocated for the Java Heap. The -ms and -mx parameters specify the initial and maximum amount of memory allocated to Java to run eFORMz. Where these values are depends on how you run eFORMz: an eformz_start.sh script contains these values (sometimes as -Xms and -Xmx), the eFORMz service on Windows should have them in jsl_ServiceManager_64.ini.
You can increase the amount of memory allocated to Java. After you update the value for -ms or -mx, save the file, close all eFORMz windows, and restart eFORMz. Increasing memory might solve problems related to much higher use and many more print jobs. However, it will not solve memory issues related to invalid data or disk storage limitations.
The following values are typically used:
| Windows Default | Heavy Use | Extreme Use |
| -ms512M | -ms2G | -ms6G |
| -mx2048M | -mx8G | -mx64G |
Assistance
If any further assistance is needed, please contact our Support team.
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